ArcGIS Basics – Hands-On Portion
9/6/2019
Research Computing Services
Instructor: Dennis Milechin

Note: RCS example programs are provided "as is" without any warranty of any kind. The user assumes the entire risk of quality, performance, and repair of any defect. You are welcome to copy and modify any of the given examples for your own use.
Contents
Opening ArcMap ................................................................. 3
Add a BaseMap ........................................................................ 7
Basic Navigation .................................................................. 9
Download Tutorial Dataset .................................................. 11
Importing Shapefiles ............................................................ 12
Exploring Attribute Table ...................................................... 25
Export Selected Data from Layer ............................................ 37
Formatting the Layers .............................................................. 41
Import a CSV file with Coordinates ...................................... 57
Adding Labels ....................................................................... 73
Subsetting by Definition Query ............................................. 77
Creating a Map Package to Share ......................................... 81
Opening ArcMap

1. Find the ArcMap executable and start the program.

2. The program will open and a window will appear called “ArcMap – Getting Started”. In this window you will see recent maps you might have worked on, or you can select a template for a new map project.
3. On the left side, the tree menu, click on “New Maps”, which will update the center panel, and select “Blank Map”. Click OK and the window will disappear and the ArcMap window in the background will now be accessible.

4. Now you should see a mostly blank ArcMap Window that looks like something below.
Let’s save this map. Click on **File → Save**

5. A new window appears. Select a location you want to save the map file, give the map a name, and then click “Save”.

Once saved, you should see a globe icon with a magnifying glass.
Now remember, ArcMap is a viewer for your data. You can’t send an this .mxd file to someone and expect them to open the file and view the data. You have to send them the data as well. We will look at a packaging option later in the tutorial.
Add a BaseMap

1. Click on the “Add Data” down arrow and select “Add Basemap…”

2. A new window will appear presenting various basemaps you can load. For this tutorial we will work with “Topographic”. Select “Topographic” and click on “Add”.

![Add Basemap dialog box with various basemap options]
3. Now you should see the basemap in the main mapping window. The basemap is coming from an ESRI online server, very similar to how you get Google Maps through your browser or on your smartphone. At the left, under the “Table Of Contents” you should see “Basemap” layer listed. If you don’t see a similar “Table of Contents” layout, then make sure the “List by drawing order” tool is selected.

4. Next to the “Basemap” layer you will see a checkbox. When the check is present, the layer will be visible in the main mapping window. When the box is unselected, the layer will not be visible in the mapping area. This allows us to select the specific data that we want to see.

5. The root of tree is called “Layers”, this is also known as the “DataFrame.” The DataFrame has properties that describe how all the data will be shown, one property is the Geographic Coordinate System and Projection.
Basic Navigation

1. Now that we have a basemap, we can practice using our navigation tools.
2. We will focus on these tools:

3. Make sure the hand tool is selected. Now move your mouse to the mapping window and click and hold the left button and move the mouse in a direction of your choice. This allows you to pan the map. You can unclick the mouse and then repeat this action.

4. You can click the back tool to go to the previous view. Or the forward button to go to the more recent extent.

5. To zoom, if you have a mouse with a scroll wheel, you can scroll the wheel towards you to zoom in and away from you to zoom out. If you don’t have a scroll, you can use the zoom in tool by clicking the zoom tool, then going to the mapping area, left click and hold and drag a box around the area you want to zoom into. To zoom out, click on the zoom out tool and draw a rectangle and it will zoom out.

6. To go back to the world view, click the Full Extent Tool.

7. You can also use the “fixed Zoom” tool. These will zoom in and out based on the current location of the center of the map.
When playing around with the zoom, you might have noticed a number ratio changing near the top. This ratio represents the current scale of the view. In this snippet, 1:500,000,000 means that a feature you see in the mapping area is 500 million times smaller than its real size.

You can type in your own ratio, or select one from the drop down menu.
Download Tutorial Dataset

1. Download the following zip file and save it to your “Documents” folder.
   
   http://rcs.bu.edu/examples/gis/arcgis/tutorial_files.zip

2. Unzip the folder. This collection contains shapefiles downloaded from the MassGIS Data Layers <https://www.mass.gov/service-details/massgis-data-layers> You can download many useful layers for Massachusetts on this website.
Importing Shapefiles

1. Let’s reset our view to the full extent by using the Full Extent Tool.

2. Click on the “Add Data” tool.

3. A new window will appear. Before we can add data, we may need to tell ArcMap where it can find this data first. This step you only have to do once for each directory you want to include.

   You will need to click on “Connect to folder” tool.
4. Again, a new window will appear. Here find and select the “tutorial_files” folder we just extracted, and click OK.

5. Now click on the drop down menu, and you should see the path to the folder we had just set under the “Folder Connections.”
6. You should see a list of folders which contain the shapefiles we will use in this tutorial.

![Image of Add Data window with folders and files]

7. Double click on the folder “outline25k”, and you will see one polygon shapefile called “OUTLINE25K_POLY.shp”, which is a polygon representing the shape of Massachusetts. Notice that in ArcMap, only one file is shown, versus if you go to the actual directory, there are many more files. Select the “OUTLINE25K_POLY.shp” file and click Add.

![Image of Add Data window with selected file]

14
You will get an error message indicating a Coordinate System warning.

![Image of Geographic Coordinate Systems Warning]

Remember the topic of Geographic Coordinate Systems? Each shapefile is assigned a geographic coordinate system and each one can be different based. The DataFrame is set to a specific coordinate system and if the shapefile doesn’t match it, then it will show this Warning. This warning is just letting you know a transformation is taking place.

We will let ArcMap handle the conversion and click “Close”.

"You will get an error message indicating a Coordinate System warning."

"Remember the topic of Geographic Coordinate Systems? Each shapefile is assigned a geographic coordinate system and each one can be different based. The DataFrame is set to a specific coordinate system and if the shapefile doesn’t match it, then it will show this Warning. This warning is just letting you know a transformation is taking place."

"We will let ArcMap handle the conversion and click “Close”.

"You will get an error message indicating a Coordinate System warning.

![Image of Geographic Coordinate Systems Warning]

Remember the topic of Geographic Coordinate Systems? Each shapefile is assigned a geographic coordinate system and each one can be different based. The DataFrame is set to a specific coordinate system and if the shapefile doesn’t match it, then it will show this Warning. This warning is just letting you know a transformation is taking place.

We will let ArcMap handle the conversion and click “Close”.

15
8. You should now see a new layer added to the “Table of Contents”. You might have a different colored rectangle, and that is OK, ArcMap chooses random colors when adding layers. In the mapping area you might see a new spec appear, that is the new layer we just added.
9. Before we proceed, let's update the DataFrame coordinate system, so we don't get this error message in the future for the Subway lines layer we will add later. Select the "Layers" DataFrame and right click, and select "Properties".
A new window will appear. Select the “Coordinate System” tab.

10. You can pick a coordinate system from the list, but if you want to apply a specific one from a shapefile, click on the down arrow of the “Add Coordinate System” tool, and select “Import”.
11. A new window will appear. Now find the shapefile we just added and select it, then click Add.
12. When we return the previous window, you will notice that it imported the Coordinate System and Projection of the shapefile and put it under “Favorites” and selected it.
Now click OK. You will get a warning message indicating that there is a layer that does not match the DataFrame coordinate system. The warning message is referring to the Basemap layer, which is always in a Web Mercator coordinate system. We will click “Yes” and proceed.

Now you should see that the projection has changed the view of the map.
13. Now we are more interested in the layer we just imported. In the “Table of Contents” right click on the layer “OUTLINE25K_POLY” and select “Zoom to Layer”.

14. Now we see this shapefile is a polygon of the state of Massachusetts. Now check and uncheck the checkbox for this layer to make it appear and disappear.
15. OK, let's add the subway lines data. Click on the "Add data" tool, and import the MBTA_ARC.shp file from the "mbta_rapid_transit" folder.

So now you should see some line added in the Boston area.
16. Now, let us focus on the Subway Lines. Select and right click on “MBTA_ARC” layer and select “Zoom to Layer”.

17. The map zooms in to the extent of the Subway Lines.
Exploring Attribute Table

1. Let us first focus on the Subway Lines. Select and right click on “MBTA_ARC” layer and select “Zoom to Layer”.

2. Let’s remove the Massachusetts polygon by unchecking the “OUTLINE25K_POLY” layer for now. If you can’t see your subway lines, let’s uncheck the Basemap as well.

3. Let’s explore the Subway Lines attributes. Let’s look at one feature at a time. Click on the “Identity” tool 🔄.
4. Now hover over a Subway Polyline and click on it. A new window should appear displaying the attributes of that Polyline.
5. You can click “x” at the top right to close it. Now looking at each record like this is not efficient, so let’s open the attribute table. Go to the “Table of Contents”, select “MBTA_ARC” and right-click, and select “Open Attribute Table”.

6. A new window appears, which contains a table. Each column is an attribute, something that describes the feature (a row), which in this case is a Polyline for the location of a Subway line.
7. I can select an entire row, by clicking on the grey cell on the far left. This will highlight the row, but it will also highlight the polyline on the map. This allows you to associate a row in the attribute table with the location on the map.

8. One can also double click on the column name to sort the column. Double click on “LINE” to group the colors. To select multiple rows, click and drag.
9. To unselect everything, click the Clear Selection button.

10. We can also select by attribute. Click on the “table Options” tool, and select “Select By Attributes...”
11. A new window will appear. This window assists us in assembling a SQL query to select features that satisfy our attribute selection. Near the top is a list of all the attributes associated with this layer. Let’s say we want to select all polylines associated with the Green Line. First double click the “LINE” attribute.
12. You will notice when you double clicked the “LINE” attribute, it added it to the text box below. This is where we are assembling a query.

SELECT * FROM MBTA_ARC WHERE: "LINE"
13. Next let’s click the “=” button.
14. Next, while the “LINE” attribute is still selected at the top list, click on the “Get Unique Values” button.

This will list all the unique values of that column.
15. Now let’s double click on the ‘GREEN’ value. This finishes the query we want, select all the polylines that have a value of “GREEN” for attribute “Line”.

```
SELECT * FROM MBTA_ARC WHERE:
"LINE" = 'GREEN'
```

16. Click on “Verify” to make sure the query does not have any errors. You should get a successfully verified message.

17. Click OK to close the message and then click “Apply” and then “Close”.
18. Now if we go back to the attribute table and scroll through it, you will notice all the rows that have “LINE” = ‘GREEN” are highlighted. They are highlighted in the map as well.
19. Click on the “Show selected records icon” on the bottom. This will only show the selected records for easy viewing.

Export Selected Data from Layer

1. We can export this result to a new Shapefile as a way to subset the data for further analysis. Using the selection from the previous exercise, go to the “Table of Contents”, select and then right click on “MBTA_ARC” layer. Then go to Data→Export Data…
2. Make sure “Selected features” is selected in the drop down menu. Click on the folder icon to select a location to save the file.

3. A new window will appear. Go to the “tutorial_files” folder. Create a new folder called “greenline”.

- [Image of Export Data dialog box with “Selected features” highlighted]
- [Image of Saving Data dialog box with “greenline” highlighted]
4. Double click on “greenline” to go into the folder, and type a name for the shapefile, “greenline.shp”, and make sure the drop down menu for “Save as type” is “Shapefile.

5. Click save. Then we are back to the “Export Data” window. Click “OK”.
6. You may see a progress bar, and then it will ask you if you want to add the layer to the map. Click yes.

![ArcMap](image1)

7. Now look at the Table of Contents and there is a layer called “greenline”. Uncheck all the other layers and make only greenline visible. Now we confirm only the greeline polylines were exported.
Formatting the Layers

1. We want to now update the colors and symbology of the map to make it visually appealing. Let’s first turn on the layer “OUTLINE25K_POLY” and zoom out to the extent of the OUTLINE25K_POLY layer.

2. In the “Layers” DataFrame, the order of the layers matter. The layer that is on bottom is drawn at the back, while the layer at the top is drawn in the front. You can reorder the drawing order of the layers by selecting a layer, left click and hold the layer, and then drag it to the level you want it appear. Let’s select “OUTLINE25K_POLY” and put it at the top.

Notice how the lines for the subways have disappeared? This is because you are drawing the Massachusetts Polygon on top of all the subway line layer. If you uncheck the polygon layer, then you will see the subway lines are still there. This is not what we want, so let’s drag the polygon layer back to right above the “basemap” layer.
3. The names of our layers are not very informative, let's update them. Select "OUTLINE25K_POLY" and right click, and go to "Properties".
4. A new window will appear. This Layer Properties will be used a lot to edit how the layer is displayed and what type of data is displayed. To update the name we want to go to the “General” tab and change the “Layer Name” field to “Mass. Border”.

Then hit “Apply”. If you look at the Table of Contents, you should see the layer name was updated.
5. Let’s explore the Layer Properties window some more. Click on the “Source” tab.

This is a useful tab to review, as it include the location of the datasource, the geometry type, the projection, and extent.
Next let’s take a look at “Symbology” tab. This is where we can update how the layer is drawn on the map. Click on the “Symbol” rectangle so we can edit the look.
7. A new window will appear. On the left pane, one can select a pre-defined symbols, or one can create their own Symbol on the right. To keep things simple let's click on the “Hollow” Symbol and click OK. The “Hollow” symbol will just place a black border around the polygon with no fill color.
8. This will close the Symbol Selector window and we are back at the Layer Properties window. You will notice the Symbol has changed to the one we selected.

To apply the change to our layer, we need to hit “Apply” or “OK”. Let’s hit “OK”, which will apply the changes but also close the window.
9. You should see that now we have a black border of the polygon with no fill color. You will also notice that the “Mass. Border” layer symbol was also updated.

10. Let’s color code the subway lines based on their colors. Let’s first zoom in on the Subways by using the “Zoom to Layer” option.

11. Then right click on “MBTA_ARC” layer and select “Properties”
10. Let’s update the layer name, by going to the “General” tab and changing the “layer Name” field to “Subway”, then hit “Apply”.

![Layer Properties dialog box with the Layer Name field set to Subway]
11. Next, let’s go to the “Symbology” tab and then on the left side, click “Categories”
12. This will update the main panel and expand the Categories options. Make sure “Unique values” is selected under “Categories.”
13. If we look at the drop down options for “Value Field”, we will notice these are the attributes of the features.

Since we want to color code by “LINE”, let’s select that Attribute.
14. Next, click on “Add All Values” button. This will list all the unique values of “LINE” attribute in the center panel.
15. The colors chosen are not representative of the Subway Line colors. Let’s update those. Select the “BLUE” value row and right click, and select “Properties for Selected Symbols(s)”. 
16. A new window will appear, and it should look a little familiar to when we updated the symbology for the Massachusetts Border. On the right side, let's select a “color” blue and increase the line width to 2.00, and Click OK.

![Symbol Selector]

17. You should see the symbology for the BLUE line is now blue and thicker.
18. Update the colors of the other lines, but this time you can just double click on the color line you want to change to get the same edit window.
19. Then click “OK” to apply the changes. Now each subway line is color coded to their corresponding line name.

Import a CSV file with Coordinates

1. Let’s add the station locations to the map. This is stored in the mbta_stations.csv which was part of the ArcGIS_Basics_Tutorial_Files.zip you downloaded earlier. If you open this file, you will see 6 columns:
   - **STATION** – The name of the MBTA station stop
   - **LINE** – What color subway line it is on
   - **TERMINUS** – Is this station the end of the line.
   - **ROUTE** – The name of the subway route
   - **POINT_X** – the X coordinate
   - **POINT_Y** – the Y coordinate
2. We can add this data to ArcMap by going to **File → Add Data → Add XY Data...**
3. A new window will appear called “Add XY Data”. First we need to tell ArcMap where this file is by clicking the folder tool.

![Add XY Data]

4. In the new window find the mbta_stations.csv file and select it, and then click “Add”.

![Add]

59
5. Now we need to specify the X Field and Y Field. These are the X and Y coordinates. So set “X Field” to “POINT_X” and “Y Field” to “POINT_Y”.

At the bottom is the Coordinate System ArcMap chose for the data, this is the same one as the DataFrame we set earlier. This is not the correct geographic coordinate system and projection, but let’s see what happens when we choose the wrong one. Click “OK”.

6.
7. When you click “OK” it will indicate that the table you have does not have an “Object-ID” field, or column, and so you might be limited on what you can do with this data set. “Object-ID” is a unique identifier for a feature and is required by ArcMap for certain actions. You can add your own “Object-ID” field in the CSV file, or after importing the file you can export the layer as a shapefile, and that will generate an “Object-ID”. For now we are ok, and we can just click “OK”.

![Table Does Not Have Object-ID Field](image)

The table you specified does not have an Object-ID field so you will not be able to select, query, or edit the features in the resulting layer, or define relates for them.

After you create this layer, you can export it to a shapefile or feature class if you need these functions. To export a layer, right-click it in the Table Of Contents and choose Data>Export Data. Add the exported data to the map as a new layer.

8. After clicking “OK”, you will notice that the points were added to the DataFrame, but you don’t see them on the map.

![Layer View](image)

Where did they go? Let’s right click on “mbta_stations.csv” layer and do “Zoom to Layer”.

61
9. Now we see them, but all the other layers are gone! This is a sign that we have selected the wrong coordinate system for this data!

10. Let’s remove this data, by right clicking on “mbta_stations.csv” and selecting “Remove”
11. Let’s return to our previous extent, either use the back button, or do a “Zoom to layer” on the “Subway” layer.

12. Let’s go back to the “Add XY Data” window by going to File → Add Data → Add XY Data...
13. Fill out the form as we did before, but this time we are going to set the coordinate system manually, by clicking the “Edit” button.
14. A new window will appear. When you receive a CSV file you need to ask what the coordinate system and projections are for the coordinates. For this file I know it is WGS 1984, as at the top search input field type in “GCS_WGS_1984” and click enter.

The panel below the search input textbox will filter down to only one coordinate system, the “WGS 1984”. Select that one and click “OK”.
15. Now we have the correct one set in the “Add XY Data” window.
16. Click, “Ok”. You will get the same “Object-ID” error message as before, just click “OK”. Now we should see the station location as points.
17. OK, now that we have the data imported, let’s export this to a Shapefile, so that the “Object-ID” field is added. Right click on the “mbta_stations.csv” layer and go to Data → Export Data...
18. A new window will appear. The default options should be good, except we want to choose where we want to save the new shapefile, so click on the folder tool.

19. A new window will appear. From the drop down menu at the top select our tutorials folder connection we had created earlier.
10. Now my personal preference is to create a folder for each shapefile, as we remember a shapefile consists of a collection of files. Click on the new folder tool.

20. A new folder will appear in the directory and name the folder “mbta_stations”. Then double click on the folder to open it.
21. Now we can name the shapefile, let's call it "mbta_stations.shp" and set "Save as type" to "Shapefile".

![Image of Saving Data dialog]

Now click "Save".

22. Now we are back at the "Export Data" window, now we can click OK.

![Image of Export Data dialog]
23. Now a new message will appear asking if you want to add this new Shapefile to the map as a layer. Click “Yes”.

![ArcMap dialog](image)

24. Now we see the newly created shapefile listed at the top of our DataFrame.

![Table Of Contents](image)

25. We can now remove the “mbta_stations_.csv” layer, by right clicking on it and selecting “Remove”.

![Table Of Contents](image)
Adding Labels

1. Let’s add labels to the stations. First let’s look at the attribute table of “mbta_stations”, by right clicking on the layer and selecting “Open Attribute Table”

2. Looking at the table column names, we see we want to use “STATION” as the source of our labels.
3. We can close the Table. Now we want to right click on the layer and click on “Properties.”
4. Then we will go to the “Labels” tab.
5. First we want to enable the labels, but clicking the “Label features in this layer” check box at the top left. And we want the “Label Field” to be set to “STATION”.
6. Now let’s click OK. Now we should see the stations labeled.

Subsetting by Definition Query
1. During this tutorial we used “Select by attribute” to select features we want and exported that to a new Shapefile. There is another way to subset data without having to export a shapefile, which we will explore now.
2. In the table of Contents, select “Subway” layer and right click and select “properties”.
3. Click on the “Definition Query” tab and then click on “Query Builder”.

![Image of the Layer Properties dialog box with the Definition Query tab highlighted and the Query Builder button circled in red.](image-url)
4. This Query Builder is identical to the one we saw earlier when we did “Select by attribute”. Let’s select the features that have a “LINE” value of “green”.

5. Click on “Verify” to confirm the query is good. Then click “OK”. Then in the “Layer Properties” window click “OK”.
6. Now you should see only the polyline for the greenline only.

7. Now open the attribute table for “Subway”. Notice only the Green line features are not shown. This can be dangerous if you forget that a Definition Query is set as it appears you are missing data!
8. You will also notice the stations point layer for the other lines are still visible. This is because “mbta_stations” is a different layer and it’s own “Definition Query” needs to be set.

Creating a Map Package to Share

1. In this section, we will review how to create a Map Package that you can share with others. Remember that ArcMap is just a data viewer, so in order to send a map to someone else, it needs to include the data as well, which is accomplished via Map Package.

2. Go to File ➔ Share As ➔ Map Package...

3. A “Map Package” window will appear. First, let’s pick a location where the package can be save and give the map package a name. Click on the browse button.
4. In the “Save Map Package” window, specify the location and name and click “Save”.
5. Now back at the “Map Package” window click on Analyze, to see if any additional requirements are needed for this map package to be saved.

6. A new window should appear that indicates errors and warnings. We need to resolve the Error in order to export the Map Package.
7. In the “Map Package”, on the left, click on “Item Description”. In order to resolve these errors, we need to fill out the “Tags”, “Description” and “Summary” sections.
8. Now click “Analyze” and the errors should go away. Now click on “Share”. It may ask you to save the map first, go ahead and save it.

![Map Package](image)

9. Once the packaging is complete, you should have a Map Package that has an icon like this:

![my_mappackage](image)